article(s) dans votre panier VOIR

Suite déclarations des permissions et composant necessaire dans le manifest

  • Vidéo 86 sur 99
  • 10h47 de formation
  • 99 leçons

Un contenu flash devrait s'afficher ici. Votre navigateur ne comporte pas de plugin flash, ou il ne s'est pas correctement initialisé.

Vous pouvez télécharger le plugin flash depuis le site d'Adobe à l'adresse suivante : http://get.adobe.com/flashplayer/.

Pour accéder à la suite de cette formation, vous devez vous abonner.
previous
summary
resume
next
play
Suite déclarations des permissions et composant necessaire dans le manifest
00:00 / 02:48
HD
fullscreen
Je m’abonne
à partir de 16,6 € / mois
  • Visionnage en ligne
  • Accès illimité à toutes nos formations
OU
J'achète uniquement
la formation
49,90€
  • Téléchargement + VOD à vie
  • Accès uniquement à cette formation

Sommaire de la formation

Détails de la formation

Dans cette vidéo, le formateur vous apprend comment déclarer les permissions et les composants dans le Manifest d’une application Java pour Android. L’objectif est de donner à l’application un accès à Google MAP. Pour ce faire, vous devez commencer par annoncer deux types d’éléments. En premier temps, vous codez la séquence de permissions suivante. Pour accéder à l’état du Network, vous entrez la commande . Par la suite, vous activer l’accès à internet à partir du code . Puis vous demandez l’utilisation des stockages externes par . Une fois faite, vous devez choisir un mode de localisation. Soit vous optez pour la géo localisation de votre Device qui est une localisation précise codifiée . Soit vous choisissez la localisation à partir des connexions Bluetooth ou WI-FI à l’aide de . Pour terminer la série de permission, il ne vous reste plus qu’à demander l’accès à Google MAP par . Par ailleurs, vous devez demander une vérification de votre Device s’il possède l’OPENGL V2 à partir de l’instruction . Cette instruction indique que si l'OPENGL n'est pas compatible avec le Device vous ne pouvez pas utiliser Google MAP dans l'application. Afin de pouvoir utiliser la Google MAP API V2 vous devez avoir au minimum une version17 du SDK. En conclusion, après le visionnage de cette vidéo vous savez comment intégrer Google MAP à votre application.